Home
All Oracle Error Codes
Oracle DBA Forum

Frequent Oracle Errors

TNS:could not resolve the connect identifier specified
Backtrace message unwound by exceptions
invalid identifier
PL/SQL compilation error
internal error
missing expression
table or view does not exist
end-of-file on communication channel
TNS:listener unknown in connect descriptor
insufficient privileges
PL/SQL: numeric or value error string
TNS:protocol adapter error
ORACLE not available
target host or object does not exist
invalid number
unable to allocate string bytes of shared memory
resource busy and acquire with NOWAIT specified
error occurred at recursive SQL level string
ORACLE initialization or shutdown in progress
archiver error. Connect internal only, until freed
snapshot too old
unable to extend temp segment by string in tablespace
Credential retrieval failed
missing or invalid option
invalid username/password; logon denied
unable to create INITIAL extent for segment
out of process memory when trying to allocate string bytes
shared memory realm does not exist
cannot insert NULL
TNS:unable to connect to destination
remote database not found ora-02019
exception encountered: core dump
inconsistent datatypes
no data found
TNS:operation timed out
PL/SQL: could not find program
existing state of packages has been discarded
maximum number of processes exceeded
error signaled in parallel query server
ORACLE instance terminated. Disconnection forced
TNS:packet writer failure
see ORA-12699
missing right parenthesis
name is already used by an existing object
cannot identify/lock data file
invalid file operation
quoted string not properly terminated

RE: [suse-oracle] ORA-12547 TNS: Lost contact in Itanium server

Zarick, Mathias

2006-04-28

Replies:
Hello Jorge,

there is a workaround for your problem by changing some
link options in ins_rdbms.mk.
try
LDFLAGS=-o $@(protected)
$(LDPATHFLAG)$(LIBHOME)
$(LDPATHFLAG)$(LIBHOME)stubs/

But the best solution:
install 9.2.0.7.0, there it should work.

Mathias


-----Original Message-----
From: jorgecab@(protected)]
Sent: Friday, April 28, 2006 3:59 PM
To: Bennett Leve
Cc: 'SuSE MailingList'
Subject: Re: [suse-oracle] ORA-12547 TNS: Lost contact in Itanium server

Thanks Bennet, You're right, the oracle binary was at zero bytes, I did
what you
told me and I get an error message, here is the output:

oracle@(protected)

- Linking Oracle
rm -f /opt/oracle/product/9ir2/rdbms/lib/oracle
gcc -o /opt/oracle/product/9ir2/rdbms/lib/oracle
-L/opt/oracle/product/9ir2/rdbms/lib/ -L/opt/oracle/product/9ir2/lib/
-L/opt/oracle/product/9ir2/lib/stubs/ -Wl,--relax  -Wl,-E,-relax `test
-f
/opt/oracle/product/9ir2/rdbms/lib/skgaioi.o && echo
/opt/oracle/product/9ir2/rdbms/lib/skgaioi.o`
/opt/oracle/product/9ir2/rdbms/lib/opimai.o
/opt/oracle/product/9ir2/rdbms/lib/ssoraed.o
/opt/oracle/product/9ir2/rdbms/lib/ttcsoi.o
/opt/oracle/product/9ir2/lib/nautab.o
/opt/oracle/product/9ir2/lib/naeet.o
/opt/oracle/product/9ir2/lib/naect.o
/opt/oracle/product/9ir2/lib/naedhs.o
/opt/oracle/product/9ir2/rdbms/lib/config.o -lserver9 -lodm9 -lskgxp9
-lskgxn9
-lclient9 -lvsn9 -lwtcserver9 -lcommon9 -lgeneric9
/opt/oracle/product/9ir2/rdbms/lib/defopt.o -lknlopt `if /usr/bin/ar tv
/opt/oracle/product/9ir2/rdbms/lib/libknlopt.a | grep xsyeolap.o >
/dev/null
2>&1 ; then echo "-loraolap9" ; fi` -lslax9 -lpls9 -lplp9 -lserver9
-lclient9
-lvsn9 -lwtcserver9 -lcommon9 -lgeneric9 -lknlopt -lslax9 -lpls9
-lplp9
-ljox9 -lserver9 -locijdbcst9 -lwwg9 `cat
/opt/oracle/product/9ir2/lib/ldflags`   -lnsslb9 -lncrypt9 -lnsgr9
-lnzjs9
-ln9 -lnl9 -lnro9 `cat /opt/oracle/product/9ir2/lib/ldflags`   -lnsslb9
-lncrypt9 -lnsgr9 -lnzjs9 -ln9 -lnl9 -lmm -lnls9 -lcore9 -lnls9 -lcore9
-lnls9
-lxml9 -lcore9 -lunls9 -lnls9 `cat /opt/oracle/product/9ir2/lib/ldflags`

-lnsslb9 -lncrypt9 -lnsgr9 -lnzjs9 -ln9 -lnl9 -lnro9 `cat
/opt/oracle/product/9ir2/lib/ldflags`   -lnsslb9 -lncrypt9 -lnsgr9
-lnzjs9
-ln9 -lnl9 -ltrace9 -lnls9 -lcore9 -lnls9 -lcore9 -lnls9 -lxml9
-lcore9
-lunls9 -lnls9 `if /usr/bin/ar tv
/opt/oracle/product/9ir2/rdbms/lib/libknlopt.a | grep "kxmnsd.o" >
/dev/null
2>&1 ; then echo " " ; else echo "-lordsdo9"; fi` -lctxc9 -lctx9 -lzx9
-lgx9
-lctx9 -lzx9 -lgx9 -lordimt9 -lnls9 -lcore9 -lnls9 -lcore9 -lnls9
-lxml9
-lcore9 -lunls9 -lnls9 -lsnls9 -lunls9 -lxsd9 -lnls9 -lcore9 -lnls9
-lcore9
-lnls9 -lxml9 -lcore9 -lunls9 -lnls9  `cat
/opt/oracle/product/9ir2/lib/sysliblist | sed "s%-lm%%"`
-Wl,-rpath,/opt/oracle/product/9ir2/lib:/lib:/usr/lib
/opt/oracle/product/9ir2/lib/libimf.a -lm   `cat
/opt/oracle/product/9ir2/lib/sysliblist | sed "s%-lm%%"` -ldl
/opt/oracle/product/9ir2/lib/libimf.a -lm  `test -f
/opt/oracle/product/9ir2/rdbms/lib/skgaioi.o && echo -laio`
/usr/lib/gcc-lib/ia64-suse-linux/3.3.3/../../../../ia64-suse-linux/bin/l
d:
/opt/oracle/product/9ir2/rdbms/lib/oracle: the symbol hidden `__divdi3'
in
/usr/lib/gcc-lib/ia64-suse-linux/3.3.3/libgcc.a(__divdi3.oS) is
referenced by
DSO
collect2: ld returned 1 exit status
make: *** [/opt/oracle/product/9ir2/rdbms/lib/oracle] Error 1

I don't understand the error message, any ideas?

Thanks a lot for the help

Jorge


Mensaje citado por Bennett Leve <bennett.leve@(protected)>:

> Jorge,
>
> ORA-12547 means the server process did not spawn. Most likely the
> "oracle" binary is not there or zero bytes.  Another possibility is
you
> are missing a shared library it needs.
>
> Do the following and report the output:
>
>  % cd $ORACLE_HOME/rdbms/lib
>  % make -f ins_rdbms.mk ioracle
>
> Thanks
>
> -Bennett
>
> jorgecab@(protected):
> > Hi everyone,
> >
> > I'm installing oracle 9ir2 in an itanium server following Novell's
guide. I
> > finished the installation with the predictable errors and proceeded
to
> install
> > the 9.2.0.5 patchset, everything went Ok until the 98% of the
installation
> > where I got the ins_rdbms.mk error, followed the instructions to fix
this
> (note
> > 285982.1) and click on retry but it didn't get fix, so I press
continue and
> the
> > patch finished the installation.
> >
> > Now when everything was done I tried to create a database with dbca
but I
> get
> > this error message:
> > ORA-12547 TNS: Lost contact
> > I've been searching google and metalink but I can't seem to find
something
> that
> > works, checked the libaio rpm's, the environment paths but still
can't make
> it
> > work, Can someone give me a hint here? plus, this is a really urgent
thing
> so
> > do you guys think that if I make the installation without the
patchset it
> will
> > work ok? I will be using this database only for a while.
> >
> > Thanks for the help
> >
> > Jorge
> >
> >
> >
> > ----------------------------------------------------------------
> > This message was sent using IMP, the Internet Messaging Program.
> >
> >
> >
>
>


--
d-_-b   \|/
      0-0
 ---oOo-(_)-oOo---

----------------------------------------------------------------
This message was sent using IMP, the Internet Messaging Program.


--
To unsubscribe, email: suse-oracle-unsubscribe@(protected)
For additional commands, email: suse-oracle-help@(protected)
Please see http://www.suse.com/oracle/ before posting



--
To unsubscribe, email: suse-oracle-unsubscribe@(protected)
For additional commands, email: suse-oracle-help@(protected)
Please see http://www.suse.com/oracle/ before posting